'metasploit'에 해당되는 글 1건

Backtrack4 Metasploit

IT/Linux 2010.06.07 16:40

BackTrack includes the Metasploit Framework, but not always the latest version. To install the latest version of Metasploit in BackTrack:

$ sudo bash
# cd /pentest/svn
# rm -rf framework3
# svn co https://www.metasploit.com/svn/framework3/trunk framework3

In order to use the raw socket modules, the pcaprub extension must be installed:

# cd /pentest/svn/framework3/external/pcaprub
# ruby extconf.rb
# make && make install

In order to use the WiFi modues, the lorcon2 extension must be installed:

# cd /pentest/svn
# svn co https://802.11ninja.net/svn/lorcon/trunk lorcon2
# cd lorcon2
# ./configure --prefix=/usr && make && make install
# cd /pentest/svn/framework3/external/ruby-lorcon2
# ruby extconf.rb
# make && make install

Once a fresh Subversion snapshot has been installed, it can be updated with the following command:

# svn update /pentest/svn/framework3/

   

원본 위치 <http://www.metasploit.com/redmine/projects/framework/wiki/Install_BackTrack>

   

블로그 이미지

BlueBell_ NINEx

일상과 IT의 만남

댓글을 달아 주세요

-->